博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
XDU 1160 - 科协的数字游戏I
阅读量:5260 次
发布时间:2019-06-14

本文共 1091 字,大约阅读时间需要 3 分钟。

Problem 1160 - 科协的数字游戏I
Time Limit: 1000MS   
Memory Limit: 65536KB   
Difficulty
Total Submit: 184  
Accepted: 32  
Special Judge: No
Description

 科协里最近很流行数字游戏。某人命名了一种不降数,这种数字必须满足从左到右各位数字成大于等于的关系,如123,446。现在大家决定玩一个游戏,指定一个整数闭区间[a,b],问这个区间内有多少个不降数。

Input
题目有多组测试数据。每组只含2个数字a, b (1 <= a, b <= 2^31)。
Output
每行给出一个测试数据的答案,即[a, b]之间有多少阶梯数。
Sample Input
1 9 
1 19
Sample Output
9
18
Hint
Source
            tclh123 
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a,b,dp[20][20],bit[20];
int dfs(int pos,int s,bool limit)
{
    if(pos==-1return 1;
    if(!limit&&~dp[pos][s]) return dp[pos][s];
    int end=limit?bit[pos]:9;
    int ans=0;
    for(int i=s;i<=end;i++)
        ans+=dfs(pos-1,i,limit&&(i==end));
    if(!limit)
        dp[pos][s]=ans;
    return ans;
}
int main()
{
    memset(dp,-1,sizeof(dp));
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        int len=0;
        a--;
        while(a)
        {
            bit[len++]=a%10;
            a/=10;
        }
        int A=dfs(len-1,0,true);
        len=0;
        while(b)
        {
            bit[len++]=b%10;
            b/=10;
        }
        int B=dfs(len-1,0,true);
        printf("%d\n",B-A);
    }
    return 0;
}
* This source code was highlighted by . ( style: Manni )

转载于:https://www.cnblogs.com/CKboss/p/3350845.html

你可能感兴趣的文章
磁盘测试工具
查看>>
代码变量、函数命名神奇网站
查看>>
redis cli命令
查看>>
Problem B: 占点游戏
查看>>
python常用模块之sys, os, random
查看>>
HDU 2548 A strange lift
查看>>
Linux服务器在外地,如何用eclipse连接hdfs
查看>>
react双组件传值和传参
查看>>
[Kaggle] Sentiment Analysis on Movie Reviews
查看>>
价值观
查看>>
mongodb命令----批量更改文档字段名
查看>>
使用&nbsp;SharedPreferences 分类: Andro...
查看>>
TLA+(待续...)
查看>>
题解: [GXOI/GZOI2019]与或和
查看>>
MacOS copy图标shell脚本
查看>>
国外常见互联网盈利创新模式
查看>>
Oracle-05
查看>>
linux grep 搜索查找
查看>>
Not enough free disk space on disk '/boot'(转载)
查看>>
android 签名
查看>>